Excel'de İç İçe EĞER

Excel'de EĞER fonksiyonu en önemli fonksiyonlardan biridir. İki ihtimalli durumlarda EĞER fonksiyonu tek başına çözüm için yeterli olmaktadır. Ancak ihtimal sayısı ikiden fazla ise ne yapacağız?

Öncelikle kısaca EĞER fonksiyonunu hatırlayalım. EĞER, bir koşula bağlı olarak farklı ihtimalleri çözebilmemizi sağlar. Şablon yapısı,
=EĞER(koşul; doğruysa; yanlışsa) şeklindedir.
Örneğin notu 50 veya yukarı olanlar için GEÇTİ, değilse KALDI yazdırmak istiyoruz. Burada koşulumuz notun 50 den büyük olması ve buna bağlı olarak ihtimaller ise GEÇTİ veya KALDI durumlarıdır. Bunun için yazacağımız EĞER fonksiyonu şu şekilde olacaktır; (karar verilecek notun A2 hücresinde olduğunu varsayalım)

=EĞER(A2>=50;"GEÇTİ";"KALDI")

ancak iki farklı ihtimal değilde daha fazla ise... Bunun için aşağıdaki soruyu inceleyelim.

Not 50'den küçük ise KALDI

50 - 69 arası ORTA

70 - 84 arası İYİ

85 yukarısı PEKİYİ

yazdıralım.

Bu burumda 4 farklı ihtimal var. Tek başına bir EĞER ile sadece iki ihtimali çözebiliyorduk. Dolayısıyla tek EĞER ile bu soruyu çözemeyiz. Ancak iç içe koyacağımız EĞER ile ihtimalleri arttırabiliyoruz. Bu sorunun yanıtı;

=EĞER(A2<50;"KALDI";EĞER(A2<70;"ORTA";EĞER(A2<85;"İYİ";"PEKİYİ")))

görüldüğü gibi 4 ihtimal vardı ve içi içe 3 EĞER kullanıldı. Dolayısıyla ihtimal sayısının bir eksiği kadar EĞER kullanmamız gerekiyor diyebiliriz.

Bu formülde her nekadar içi içe eğer fonksiyonu kullanılarak uzun bir formül ortaya çıkmış olsa da, EĞER fonksiyonunun şablon yapısının hiç bozulmadığına dikkat edin. Yani herbir eğerin 3 bölümden oluştuğunu yani (koşul; doğruysa ; yanlışsa) yapısının bozulmadığını ve açılan parantez kadar paratez kapatıldığına dikkat edin.

 Kayseri Düzey Bilgisayar Eğitim Merkezi'nde  İleri Excel Kursuna katılarak  exceli hızlı ve işlevsel şekilde kullanmanızı sağlayacak yöntemleri öğrenebilirsiniz.

İLERİ EXCEL KURSLARIMIZ hakkında bilgi için tıklayınız

anahtar kelimeler:ileri excel kursu kayseri excel eğitimi iç içe eğer fonksiyonu 

İleri Excel Kursu hakkında bilgi almak için tıklayınız...

 

Yorum Yap

(Büyük/Küçük Harfe duyarlı)

Yorumlar

ÇOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOK TEŞEKKÜRLER  2017-12-27 15:33:54

ÇOK SAĞOLUN

Orkun
çok teşekkür ederim  2015-01-07 08:48:36

sınavda çıkacaktı sayenizde 100 aldım emeği geçen herkese teşekkür ederim

nisanur önal
teşekkür ediyorum size  2014-11-20 18:19:17

sınavda cıkacak ama ben bu konuda takıldım şimdi ögrendim..

beyza özdemir
teşekkürler  2014-11-13 19:35:17

Bu bilgi çok işime yaradı.İleri excel kurslarınıza katılmak isterim.

Aydan Berk
 2016-01-13 18:44:17

teşekkürler yarın sınavım var ve ben bunu bilmiyordum hocada soracaktı sınavda bur dan bakıp öğrendim :) :) :) :)

ARDA
çok iyi  2016-01-13 23:25:25

çok güzel bir bilgi. eğer formülünü biliyordum ama iç içe yazılabildiğini sayenizde öğrendim. çok sağolun.

Ahmet